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Quick Start Guide

This chapter gets you making music in under five minutes. For full details on any topic, see the rest of the manual.

1. Add a Sound Source

Click the Modules button (top-left) or right-click the canvas. Choose a source node:

• Pattern — draw notes on a piano roll

• Generator — let Noemi compose probabilistic melodies for you

• Rhythm — program drum beats on a step grid

• Waveform — play back and mangle audio samples

The node appears on the canvas. Most sources come with default content so you’ll hear something right away.

2. Add an Instrument

Click Modules again and choose an instrument — Chirusa (synth), Leeroy (drums), Cantia (voice), or any installed 

VST3/AU/CLAP plugin. It appears as a second node on the canvas.

3. Connect Them

Drag from the source node’s output port (right side, orange dot) to the instrument’s input port (left side, blue dot). 

A connection line appears. You can also select a node and press C, then click the target node.

4. Connect to the Mixer

Every project has a Mixer node on the right side of the canvas. Drag from your instrument’s output port to one of 

the Mixer’s input ports. This routes audio to the master output.

5. Press Play
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Click the Play button in the transport bar (bottom-left) or press Space. You should hear your composition playing.

Adding Effects

Add an effect node (internal effects like Delay, Reverb, Filter, or any external audio plugin) and insert it between the 

instrument and the Mixer. Disconnect the instrument from the Mixer, then wire: Instrument → Effect → Mixer.

Modulation

Open the Modulation panel (bottom bar). Add an LFO, Envelope, or Step Sequencer modulation source, then route 

it to any parameter. This adds movement and variation to your sound automatically.

Scenes

Save the current state of your entire project as a Scene with Cmd+Shift+1 (or any number 1–0). Recall it with 

Cmd+1. Scenes remember all node states, modulation, and mixer settings — great for live performance.

Saving Your Work

Cmd+S saves the project. Cmd+Shift+S saves as a new file. Projects are saved as .nmi  files that include all node 

data, connections, modulation, and embedded audio.

Tips

• Right-click any node for context actions (duplicate, delete, rename, disconnect)

• Tab toggles the minimap for navigating large graphs

• Cmd+Z / Cmd+Shift+Z for undo/redo (100 levels)

• F1 opens this documentation inside the app

• Each source node has a Randomize button (!!!) to quickly generate new content

• Use the Sequencer node to automate state changes on Pattern/Generator/Rhythm for evolving arrangements
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Overview

The Noemi node canvas

Noemi is a non-deterministic composition machine. Instead of traditional linear sequencing, it uses a node-based 

graph where you wire together different composition building blocks to create evolving, generative music.

Signal Flow

Audio and MIDI signals flow left-to-right through the node graph:

Source Nodes (Pattern, Generator, Rhythm, LiveCode, Waveform, Slicer, Granular)

→ Transformer Nodes (modify notes/timing)

→ Instrument/Effect Nodes (produce/shape sound)

→ Mixer (master output)
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Source nodes generate or play back musical data. Transformers process that data in real-time. Instruments convert 

MIDI to audio. Effects process audio. Everything routes to the Mixer for final output.

Node Types

Node Description

Pattern MIDI piano roll with 4 independent playheads

Generator Rule-based probabilistic note generation

Rhythm 8-lane drum step sequencer

LiveCode Text-based pattern generator using mini-notation

Waveform Audio sample player with 4 playheads

Slicer MIDI-triggered audio slicer with transient detection

Granular Granular synthesis with free-running and MIDI-triggered modes

Sequencer Automates state changes on Pattern/Generator/Rhythm

MIDI Output Sends notes to external hardware or other apps

MIDI Input Receives from external MIDI controllers or apps

Audio Input Receives live audio from system input or DAW effect chain

Transformer Processes notes in real-time (12 types)

Cantia Formant voice synthesizer with phoneme sequencing

Chirusa Built-in 4-oscillator subtractive synth

Leeroy Synthesis-based drum machine with 8 channels

Ostion Built-in 8-slot drum sampler

SimSim Wavetable morphing synthesizer with dual oscillators

Internal Effects Chorus, Compressor, Delay, EQ, Multimode Filter, Phaser, Reverb

OSC Input Receives OSC note messages from external controllers

OSC Output Sends generated notes as OSC messages

Plugin Hosts external AU/VST3/CLAP/LV2 instruments and effects

Mixer Master output with per-channel mixing, bus effects, mastering chain, and spectrum analyzer
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Multi-State

Pattern, Generator, and Rhythm nodes support up to 16 states (labeled A through P). Each state stores independent 

data — different notes, different hits, different generation rules. Switch states manually with the State Selector widget, 

or automate state changes with a Sequencer node.

Connections

Nodes connect via ports. MIDI signals (note data) flow from sources through transformers to instruments. Audio 

signals flow from instruments through effects to the mixer. You can create complex routing by wiring multiple 

sources to the same instrument, or splitting one source to many destinations.
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Canvas & Connections

THE NODE CANVAS

The canvas is your workspace for building compositions. Nodes appear as colored blocks that you can arrange freely.

CREATING NODES

Use the toolbar buttons at the top of the window:

Modules Add Pattern, Generator, Rhythm, or Waveform nodes

Instruments Add Chirusa, Ostion, Leeroy, Cantia, SimSim, or external AU/VST3/CLAP/LV2 plugins

Effects Add internal or external audio effect plugins

You can also right-click the canvas background to open a context menu with all node types, including the preset 

clip libraries for Pattern, Rhythm, and Waveform.

SELECTING AND MOVING NODES

• Click a node to select it (highlighted border appears)

• Drag a node to reposition it on the canvas

• Click-drag on empty canvas to rubber-band select multiple nodes

• Cmd+click  a node to add/remove it from the selection

• Drag any selected node to move all selected nodes together

• Click the canvas background to deselect

RENAMING NODES

Double-click a node’s editor panel header to set a custom display name. The custom name appears on the canvas 

and in mixer strips. Clear the name to revert to the default auto-generated name.

CREATING CONNECTIONS

• Drag from a node’s output port (right side) to another node’s input port (left side)

• A cable appears connecting the two nodes

• MIDI connections carry note data; audio connections carry sound

• Cables are color-coded: amber for MIDI, blue for audio, gold for control signals

SIGNAL FLOW VISUALIZATION
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Active connections display animated flow particles that travel along the cable from source to target, with speed 

varying by signal type (MIDI fastest, audio medium, control slowest). When MIDI notes pass through a connection, 

the cable brightens and thickens with a fast-decay pulse effect. Modulation routes show a small inline waveform 

preview of the current modulation shape.

COPY, CUT, AND PASTE

• Cmd+C  copies the selected node(s)

• Cmd+X  cuts the selected node(s)

• Cmd+V  pastes — creates new nodes with unique IDs and reconnected internal wiring

Multi-node copy/paste preserves connections between the copied nodes.

DELETING

• Select a node and press Delete or Backspace to remove it

• Multi-select and delete removes all selected nodes at once

• Right-click a connection cable to delete it

NODE GROUPING

Select 2 or more nodes and press Cmd+G  to group them into a single macro node. Double-click a group to 

enter group view and edit the subgraph inside. Press Escape to exit group view. Select a group node and press 

Cmd+Shift+G  to ungroup (dissolves back to individual nodes).

Groups have I/O nodes that define signal routing in and out of the group. Internal connections are preserved. Cable 

colors on group ports reflect the actual signal type of the internal connections (blue for audio, amber for MIDI, gold 

for control).

ZOOM AND PAN

Shortcut Action

Cmd+=  or scroll up Zoom in

Cmd+-  or scroll down Zoom out

Cmd+F Fit all nodes in view

Home Reset zoom to 1.0 and pan to origin

Middle-mouse drag or Space+drag Pan the canvas
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MINIMAP

A small overview in the top-left corner of the canvas shows all nodes as colored rectangles with a cyan viewport 

rectangle indicating the current view. Click or drag on the minimap to quickly pan the canvas to any location. Press 

Tab  to toggle minimap visibility, or use View > Toggle Minimap.

DRAG AND DROP

• Drag a MIDI file ( .mid ) onto the canvas to create a Pattern with those notes

• Drag an audio file onto the canvas to create a Waveform

• Drag an audio file onto an existing Waveform node to replace its audio
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Pattern

The Pattern editor with piano roll and 4 playhead lanes

The Pattern node is a MIDI piano roll with 4 independent playhead lanes.

STATES (A–P)

Pattern supports up to 16 states. Each state stores its own set of notes, loop region, lane configs, mutation settings, 

and output routing. Use the State Selector below the editor to navigate between states, duplicate the current state, 

or add new ones. A Sequencer node can automate state switching during playback.

PIANO ROLL EDITOR

Open the Pattern editor by double-clicking the node or selecting it and pressing Enter. The editor shows a grid with 

pitch on the vertical axis and time (beats) on the horizontal axis.

• Click to place a note

• Drag a note to move it

• Drag the right edge of a note to resize it

• Right-click a note to delete it

• Click a note to select it; Shift+click to toggle; Cmd+A to select all

• Scroll vertically to see more pitches

VELOCITY & EXPRESSION LANE

Below the piano roll grid, a velocity lane displays Ableton-style lollipop stems for per-note editing. Click the mode 

label to cycle through five modes:

Vel Note velocity (0–127)

AT Polyphonic aftertouch per note

Prs MPE pressure (channel pressure, 0–1)
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Sld MPE slide (CC74, 0–1)

PB MPE pitch bend (bipolar, −1 to +1)

Each mode uses a distinct color. When notes are selected, only the selected notes’ stems are highlighted and editable. 

MPE expression values are sent as per-note messages when connected to an MPE-capable instrument or MIDI 

Output node.

4 PLAYHEAD LANES

Each Pattern has 4 independent playhead lanes, color-coded:

Lane Color Default

Lane 1 White Enabled by default

Lane 2 Coral Disabled

Lane 3 Teal Disabled

Lane 4 Yellow Disabled

Each lane can be configured independently:

Speed Ratio Playback speed multiplier (e.g., 0.5 = half speed, 2.0 = double)

Direction Forward, Reverse, or Pendulum (alternating)

Pitch Offset Transpose in semitones

Inverted Mirror pitches around middle C

Velocity Velocity multiplier for notes on this lane

Multiple lanes reading the same notes at different speeds and directions create polyrhythmic textures.

LOOP CONTROLS

Loop Start Where the loop region begins (in beats)

Loop End Where the loop region ends

All lanes share the same loop region.

OUTP UT ROUTING

Merged All lanes output together (default)

Per Lane Each lane outputs separately (4 independent outputs)

Per-lane routing lets you send each playhead to a different instrument.

TRANSFORMS

The Pattern editor toolbar provides non-destructive transforms: Transpose, Reverse, Stretch, and Quantize.

13



Noemi Documentation Tweakbench

MUTATION

Mutation adds controlled randomness to pattern playback. When enabled, notes gradually drift from their original 

positions each time the pattern loops.

Pitch Drift Probability of pitch shifting per note

Timing Drift Maximum timing offset in beats

Velocity Drift Maximum velocity variation

Note Drop Probability of dropping a note

Note Add Probability of adding a note

Drift Accumulate 0 = fresh each loop, 1 = cumulative drift

Max Pitch Dev Maximum semitones a note can drift from baseline

Use “Capture Baseline” to save the current pattern state, and “Reset to Baseline” to restore it.

RECORDING

Arm a Pattern (or Rhythm) for live MIDI recording with the Record button in its editor toolbar. Once armed, 

recording starts in either of two ways, FL Studio style:

Play on first note With the transport stopped, the first MIDI note you play starts the transport and begins 

recording immediately from the top of the pattern.

Count-in Press Play (or Space) while armed to count in four beats on the metronome, then start recording. Notes 

played during the count-in are heard but not captured.

Play notes via a MIDI controller or the on-screen QWERTY keyboard. Captured notes are written into the armed 

module’s clip in sync with the transport. Recording ends when you stop the transport or disarm the Record button.

MODULATION TARGETS

Transpose −24 to +24 semitones

Velocity Scale 0.0 to 2.0

Swing 0.0 to 1.0

14



Noemi Documentation Tweakbench

Generator

The Generator editor with rule-based note generation

The Generator node creates notes algorithmically using configurable musical rules. Instead of fixed notes, it 

generates new material each time it plays, guided by probability and music theory.

STATES (A–P)

Generator supports up to 16 states. Each state stores its own scale, harmony, rhythm, contour, and dynamics rules.

SCALE RULE

Scale Choose from the scale library (Major, Minor, Dorian, etc.)

Root Note The tonic pitch (default: Middle C)

Octave Range Number of octaves to span (default: 2)

Base Octave Center octave (default: 4)

DEGREE WEIGHTS

Each scale degree (1 through 7) has a probability weight controlling how often it appears. Higher weight = more 

likely. For example, boosting the 1st and 5th degrees creates music that emphasizes the tonic and dominant.

RHYTHM RULE

Note Probability Base chance of generating a note (0–1)

Rest Probability Chance of silence (0–1)

Duration Weights Relative probability of different note lengths

Rhythm sources include Library presets, L-System grammars, Density Curves, and Nested Euclidean patterns.

HARMONY RULE
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Chord Progression Enable harmonic movement

Chord Change Prob How often chords change (per bar)

Chord Tone Bias Preference for chord tones (0 = none, 1 = strong)

Progression modes: Probabilistic (music-theory-based) or Template (preset progressions from library).

CONTOUR RULE (MELODIC SHAPE)

Shapes: Free, Ascending, Descending, Arch, Valley, Random Walk, Pendulum.

Strength How strongly the contour affects generation (0–1)

Phrase Length Notes per phrase cycle

Step Bias Preference for stepwise motion vs. leaps (0–1)

Max Leap Maximum interval in scale degrees

DYNAMICS RULE

Base Velocity Starting velocity level (0–1)

Velocity Range Amount of random variation

Accent Prob Chance of an accent

Accent Amount Extra velocity for accents

Humanization Random timing and velocity variations (0–1)

EXPRESSION RANGES (MPE)

The Generator can assign per-note MPE expression values. Each expression dimension has a min/max range — 

generated notes receive a random value within that range:

Pressure Min/max channel pressure (0–1)

Slide Min/max CC74 slide (0–1)

Pitch Bend Min/max pitch bend (−1 to +1)

Set both min and max to zero to disable a dimension.

FREEZE

Click “Freeze” to capture the generator’s output as a fixed Pattern. Useful for keeping a particular generation you like.

LEARN STYLE

Click “Learn Style” to analyze an existing Pattern or Rhythm node and automatically configure the Generator’s rules 

to match its musical style. A popup menu lists all nodes with data. On selection, the Generator extracts:

• Scale Rule: detected key, root note, octave range, and per-degree probability weights

• Rhythm Rule: note/rest probability, common durations, and best-fit rhythm pattern

• Dynamics Rule: base velocity, velocity range, accent probability and amount

• Contour Rule: detected melodic shape and strength
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• Phrase and Motive: estimated phrase length and motive length

All Generator controls update immediately to reflect the learned settings. You can then fine-tune individual rules or 

use the Generator as-is to produce new material in the same style.

GENERATE VARIATIONS

After configuring a Generator (manually or via Learn Style), click “Generate Variations” to produce multiple varia

tions and store them as new states on a target node. A popup menu lists all Pattern and Rhythm nodes as targets. 

The Generator creates 4 variations, each with a different random seed, and adds them as new states (up to the 16-

state limit).

This is useful for quickly populating a Pattern or Rhythm with related but distinct material that can be sequenced 

via a Sequencer node or switched manually.

MODULATION TARGETS

Density 0.0 to 1.0 (note probability multiplier)

Pitch Center 36 to 96 (MIDI note)

Pitch Range 0 to 48 semitones

Velocity 0.0 to 1.0

Duration 0.125 to 4.0 beats

Humanize 0.0 to 1.0
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Rhythm

The Rhythm editor — 8-lane drum step sequencer

The Rhythm node is an 8-lane drum step sequencer optimized for percussion programming.

STATES (A–P)

Rhythm supports up to 16 states. Each state stores its own hits, lane configurations, and loop region.

DRUM GRID

The editor displays 8 horizontal lanes. Click grid cells to toggle hits on or off. Each hit has a velocity value.

Lane Instrument MIDI Note

1 Kick 36

2 Snare 38

3 Closed HH 42

4 Open HH 46

5 Clap 39

6 Low Tom 45

7 Crash 49

8 Ride 51

You can reassign any lane to a different MIDI note to match your instrument.
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EDITING HITS

• Click a cell to toggle a hit on/off

• Left-click an existing hit to select it; Shift+click to multi-select

• Right-click a hit to delete it

• Click a lane label to focus the velocity lane on that drum row

• Right-click a lane label to change its MIDI note assignment

• Use “Clear” to clear a single lane or all lanes

VELOCITY LANE

Below the drum grid, a velocity lane shows lollipop stems for per-hit velocity editing. Click a lane label to scope the 

velocity display to a single drum row. When hits are selected, only their stems are highlighted and editable.

OUTP UT ROUTING

Merged All lanes output together (default)

Per Lane Each lane outputs on a separate channel (8 independent outputs)

MODULATION TARGETS

Velocity Scale 0.0 to 2.0

Swing 0.0 to 1.0
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Waveform

The Waveform editor — audio sample player with 4 playhead lanes

The Waveform node is an audio sample player with 4 independent playhead lanes.

LOADING AUDIO

• Drag an audio file onto the Waveform node on the canvas

• Or use the “…” button in the editor to browse for a file

• Or select from the built-in wave presets via right-click menu

• Supported formats: WAV, AIFF, FLAC, MP3, OGG

4 PLAYHEAD LANES

Like the Pattern node, each Waveform has 4 independent lanes with Speed Ratio, Direction (Forward/Reverse), Gain 

Scale, and Looping controls.

SAMPLE & LOOP REGION

Sample Start/End Defines which portion of the audio file is active

Loop Start/End Within the sample region, controls what portion repeats

TIME-STRETCH MODES

Repitch Changing speed also changes pitch (classic sampler behavior)

Stretch Maintains original pitch when changing speed (time-stretching)
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FEATURES

• Zero-crossing snap reduces clicks at loop points

• Beat length snap aligns to clean bar lengths (1, 2, 4, 8, or 16 bars)

• Output routing: Merged or Per Lane

SCRIBBLE

Scribble is an audio scrubber that lets you click-drag on the waveform to create stuttery, pitch-mangled remixes of 

the loaded audio.

1. Click Scribble in the toolbar to arm — the button turns red and shows “Done”

2. Click-drag on the waveform display to scrub audio:

• Mouse X controls the playback position in the source audio

• Mouse Y controls pitch: center = original pitch, top = 2 octaves up, bottom = 2 octaves down

• Audio plays forward from the mouse position in chunks, snapping back to the current cursor when each chunk 

ends

3. The window size slider (10–500 ms) controls chunk length:

• Small values (10–30 ms) produce rapid glitchy stutters

• Medium values (80–150 ms) create choppy, recognizable sample chunks

• Large values (300–500 ms) play longer phrases before retriggering

4. Release the mouse to stop audio — click-drag again for another gesture (gestures accumulate)

5. Click Done to finalize: the captured audio replaces the Waveform’s source file

MODULATION TARGETS

Gain 0.0 to 2.0
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Slicer

The Slicer editor with transient detection and slice markers

The Slicer node is a MIDI-triggered audio slicer. It loads an audio file, divides it into slices, and plays individual slices 

triggered by incoming MIDI notes.

LOADING AUDIO

• Use “Load File” to browse for a WAV file

• Use “Wave Library” to select from built-in audio

• Use “YT” to fetch audio from a YouTube URL

• Supported formats: WAV, AIFF, FLAC, MP3, OGG, REX2

SLICE MODES

Detect Energy-based transient detection (automatic slice placement)

1/8 Even division at 8th-note intervals

1/16 Even division at 16th-note intervals

The Sensitivity slider controls detection aggressiveness. Slice markers automatically snap to the nearest zero-

crossing.

TRIGGERING SLICES

Each slice maps to a MIDI note starting at C2 (MIDI note 48). Connect a Pattern, Generator, or Rhythm node to the 

Slicer’s input, and notes in the C2+ range will trigger the corresponding slices.

Click on a slice in the editor waveform display to preview it. Active slices glow during playback.
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SCRIBBLE

The Slicer also supports Scribble for creating stuttery remixes. When scrubbing across slice boundaries, the playback 

snaps to the start of each new slice. Click Done to replace the Slicer’s audio with the captured output — transient 

detection is automatically re-applied to the new audio.
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Granular

The Granular editor — granular synthesis with free-running and MIDI-triggered modes

The Granular node is a granular synthesis engine that reads short overlapping grains from a loaded audio file. It 

supports two modes: free-running (continuous grain generation) and MIDI-triggered (grains spawn on note events).

LOADING AUDIO

• Use “Load File” to browse for an audio file

• Use “Wave Library” to select from 9 built-in waves (Amber, Breeze, Crystal, Drift, Echo, Frost, Glaze, Haze, Ivory)

• Drag an audio file onto the node

• Supported formats: WAV, AIFF, FLAC, MP3, OGG

MODES

Free-Running Grains are continuously scheduled based on the Density parameter. Audio plays whenever the 

transport is running.

MIDI-Triggered Grains are spawned by incoming MIDI note events. Pitch derives from the MIDI note number 

relative to root note C4 (MIDI 60).

PARAMETERS

Parameter Range Description

Position 0–1 Read position in the audio file

Grain Size ms Duration of individual grains
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Density Hz Grain spawn rate (free-running mode)

Scatter 0–1 Random offset of grain start positions

Pitch semitones Pitch shift applied to grains

Pan Spread 0–1 Stereo spread of grain panning

Reverse Prob 0–1 Chance each grain plays backwards

Gain dB Master output level

All parameters are modulatable via the Modulation Matrix. The engine supports up to 64 simultaneous grains.

ENVELOPE SHAPES

Hann Smooth cosine window (default)

Triangle Linear rise and fall

Trapezoid Flat top with linear slopes

The Randomize button (“!!!”) generates a random grain configuration for sound exploration.
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LiveCode

The LiveCode editor — text-based pattern generation using mini-notation

The LiveCode node is a text-based pattern generator inspired by TidalCycles and Strudel. Instead of placing notes 

on a grid, you type a mini-notation expression that describes the musical pattern. Text changes take effect at the 

next cycle boundary, making it safe for live performance.

Mini-Notation Basics

The mini-notation uses a concise syntax where note names and numbers are spaced to divide a cycle evenly:

c4 e4 g4 b4        Four quarter notes per cycle

c4 [e4 g4] b4      e4 and g4 subdivide into the same time as c4

c4 ~ g4 ~           Rests with ~

c4*3                Repeat c4 three times in its slot

[c4 e4 g4 b4]/2    Stretch over 2 cycles (half speed)

Phase 2 Operators

Syntax Name Description

<a b c> Alternation Picks one child per cycle, cycling through

[a,b,c] Stack All children play simultaneously (chords)
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a(3,8) Euclidean Bjorklund algorithm: 3 hits spread over 8 slots

a?0.5 Probability 50% chance to play

a|b|c Random Choice Random pick per evaluation

a:0.3 Velocity Set per-note velocity (0–1)

a@2 Elongation Event occupies 2 weighted time slots

Euclidean rhythms accept an optional rotation: c4(3,8,2)  shifts the pattern by 2 positions.

Pattern Transformations

Transform keywords wrap a pattern and modify its output:

Transform Description

rev "c4 e4 g4" Reverse event order

fast 2 "c4 e4 g4" Compress and tile 2x (double time)

slow 2 "c4 e4 g4" Stretch over 2 cycles (half time)

off 0.25 "c4 e4 g4" Layer original + copy offset by 0.25 cycles

degrade "c4 e4 g4" Randomly drop  50% of events

every 4 (rev) "c4 e4 g4" Apply transform every Nth cycle

Transforms can be nested and combined with operators for complex evolving patterns.

Multi-Parameter Events

Per-note gate control for staccato and legato:

c4~0.15 e4~0.15 g4~0.15    Short staccato (15% of slot)

c4~1.0 e4~0.1              Legato C, staccato E

c4:0.3 e4:1.0              Quiet C, loud E (velocity)
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Continuous Functions

Waveform keywords produce continuous 0–1 values, useful as modulation sources:

sine  · saw  · square  · tri  · rand  · perlin

These compose with operators: fast 4 sine , [sine,saw] , every 2 (rev) saw .

Polymetric Patterns

Fit N events cyclically into M time slots for cross-rhythmic patterns:

{c4 e4 g4}%8        3 notes cycling over 8 slots

{c4 d4 e4 g4 a4}%4  5-note pentatonic over 4 beats

Conditionals

Syntax Description

sometimesBy 0.5 (rev) "pattern" Apply transform with probability

whenmod 8 4 (fast 2) "pattern" Apply transform on cycles where cycle % 8 >= 4

struct "1 0 1 1" "pattern" Rhythmic mask: play only where mask is nonzero

Slicer Mode

The mode toggle at the bottom of the editor switches between:

Notes Numbers are MIDI pitches (default behavior)

Slices Numbers are slice indices, offset by root note 48 for Slicer control

In Slices mode, 0 3 [1 2] 7  triggers slices 0, 3, 1 & 2 subdivided, and 7 on the connected Slicer node.

Multi-State
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LiveCode supports up to 8 states, each with its own pattern text. Switch states with the State Selector or automate 

with a Sequencer node.

Parameters

Parameter Range Description

Cycle Length 0.25–16 beats Duration of one pattern cycle

Transpose −24 to +24 st Semitone offset applied to all notes

Velocity 0.0–1.0 Global velocity multiplier

Swing 0.0–1.0 Swing amount for even-numbered events

All parameters are modulatable via the Modulation Matrix.

Snippet Library

Click the “Snippets” button to browse 80+ categorized pattern examples covering basic melodies, Euclidean rhythms, 

probability textures, transforms, continuous functions, polymetric patterns, conditionals, slicer patterns, and com

bined techniques.
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Sequencer

The Sequencer editor — automates state switching

The Sequencer node automates state switching on a target Pattern, Generator, or Rhythm node. It holds a sequence 

of up to 32 steps, each referencing a state (A–P). When the target node completes a loop, the Sequencer advances to 

the next step.

STEP GRID

The editor shows an 8×4 grid (32 steps). Click a cell to set which state that step activates.

CONNECTING TO A TARGET

Connect the Sequencer’s output to a Pattern, Generator, or Rhythm’s control input. The Sequencer automatically 

detects the target’s available states.

END MODES

Loop Restart from the beginning after the last step

Hold Last Stay on the final step after reaching the end

Jump to Step Jump to a specific step number after the last step
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MIDI Output

MIDI Output node — sends notes to external devices

The MIDI Output node sends generated notes to external MIDI hardware or other applications.

SETUP

1. Add a MIDI Output node via Modules > MIDI Output

2. Connect any MIDI-producing node to its input

3. Select a MIDI output device from the dropdown

4. Choose a MIDI channel (1–16)

FEATURES

• Activity indicator when notes are being sent

• Device dropdown lists all available MIDI output devices

• Refresh button to detect newly connected devices

• Active pitch tracking ensures proper note-off messages
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MIDI Input

MIDI Input node — receives from external controllers

The MIDI Input node receives notes from external MIDI controllers and applications, routing them into the Noemi 

graph.

SETUP

1. Add a MIDI Input node via Modules > MIDI Input (or right-click canvas > I/O)

2. Select a MIDI input device from the dropdown

3. Choose a MIDI channel (1–16, or All)

4. Connect the output to any MIDI-consuming node (instruments, transformers, etc.)

FEATURES

• Per-node device and channel selection (multiple MIDI Input nodes can listen to different devices)

• Activity indicator when notes are being received

• Refresh button to detect newly connected devices
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Audio Input

The Audio Input node receives live audio from the system audio device (standalone mode) or from the host DAW’s 

effect chain (plugin mode). It allows external audio to be routed into the Noemi graph for processing with effects or 

mixing alongside generated material.

CONTROLS

• Gain — Input level from −inf to +12 dB

• Mono — Toggle to sum stereo input to mono

• Device — Audio input device selector (standalone only; in plugin mode the input is fixed to the host DAW)

ROUTING

Audio Input has a single audio output port. Connect it to any effect node or directly to the Mixer. For example: Audio 

Input → Filter → Reverb → Mixer.

PLUGIN MODE

When Noemi runs as an AU/VST3/CLAP plugin, the Audio Input node receives audio from the host DAW’s effect 

chain. This makes Noemi function as an audio effect — external audio passes through Noemi’s processing graph and 

returns to the DAW. Combined with generative MIDI sources and modulation, this enables reactive, evolving audio 

effects driven by Noemi’s composition engine.
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OSC Input / Output

Noemi supports Open Sound Control (OSC) for remote control from tablets, phones, and other software. Configure 

OSC via File > OSC Settings.

OSC SETTINGS

• Enable/Disable toggle to start or stop the OSC receiver and sender

• Receive Port (default 9000) — listens for incoming OSC messages

• Send Host (default 127.0.0.1) and Send Port (default 9001) — where outgoing messages are sent

• Activity counters show incoming and outgoing message rates

BUILT-IN OSC COMMANDS

The following addresses are handled globally by the OSC service:

Address Arguments Action

/transport/play none Start playback

/transport/stop none Stop playback

/transport/tempo float Set tempo (BPM)

/scene/1  – /scene/16 none or float > 0 Recall scene N

OSC INP UT NODE

The OSC Input node receives OSC note messages and routes them into the composition graph, similar to the MIDI 

Input node.

1. Add via Modules > OSC Input (or right-click canvas > I/O)

2. Configure the note address (default /note ) and note-off address (default /noteoff )

3. Connect the output to any MIDI-consuming node

OSC OUTP UT NODE

The OSC Output node sends generated NoteEvents as OSC messages to external applications.

1. Add via Modules > OSC Output (or right-click canvas > I/O)

2. Configure target host/port and note/note-off addresses
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3. Connect any note-producing node to the input

OSC MODULATION SOURCE

Any OSC address can be used as a continuous modulation source. Add an OSC source in the Modulation Matrix 

with the “+ OSC” button. Features include:

• Address learning: click Learn, then move a control on your OSC device to auto-capture the address

• Range mapping: set expected min/max values from the incoming OSC source

• Bipolar mode: output −1 to +1 instead of 0 to +1

• Smoothing: one-pole lowpass filter for smooth parameter changes
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Transformers

Transformer nodes process notes in real-time

Transformers process notes in real-time as they flow through the graph. Connect a source node’s output to a 

transformer’s input, then connect the transformer’s output to an instrument.

Type Description Modulatable

Probability Gate Randomly passes or blocks notes Probability

Transpose Shifts all notes by semitones Semitones

Velocity Scaler Adjusts velocities with scale + offset Scale, Offset

Note Filter Passes notes within pitch/velocity ranges —

Chord Generator Expands each note to a full chord —

Arpeggiator Arpeggiates held notes Rate

Euclidean Rhythm Applies Euclidean rhythm pattern —

Humanize Adds random timing/velocity variation Timing, Velocity
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Scale Quantizer Forces notes to nearest scale degree —

Random Transpose Random pitch shift per note Min/Max Semitones

Markov Chain Learns transitions, generates variations Temperature

Style Learner Multi-dimensional style learning and generation Temperature, Similarity

The Markov chain builds a transition matrix from incoming notes and uses it to generate melodically related 

variations. Lower temperature stays closer to learned patterns; higher temperature adds more randomness.

Style Learner

The Style Learner is an advanced transformer that analyzes musical input across multiple dimensions — pitch, 

rhythm, velocity, intervals, and contour — and uses a multi-dimensional Markov model to generate or transform 

notes in the learned style.

MODES

Mode Behavior

Learn Analyzes incoming notes and builds an internal style model. Notes pass through unchanged.

Generate Self-triggers new notes at the learned density rate, using the model to choose pitches, durations, 

and velocities. No input required.

Transform Accepts input notes and modifies their pitch, velocity, and duration to match the learned style.

Both Learns from input notes and transforms them simultaneously.

PARAMETERS

Parameter Range Description

Order 1–3 Context depth for the Markov model. Higher values capture longer melodic phrases 

but need more data to learn.

Temperature 0.0–1.0 Randomness in note selection. 0 = always pick the most likely next note. 1 = uniform 

random from all learned options.

Similarity 0.0–1.0 How closely the output follows the learned model (Transform mode). 0 = input 

unchanged. 1 = fully reshaped to match the style.
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LOADING FROM A NODE

Click “Load from Node…” to bulk-learn from an existing Pattern or Rhythm node. A popup menu lists all nodes that 

contain note data. Selecting one analyzes the entire contents and populates the model instantly — useful when you 

want to learn a style without routing live notes through the transformer.

WHAT THE MODEL LEARNS

The Style Learner captures a rich statistical profile of the input material:

• Pitch: pitch-class histogram (which notes appear most), detected key and scale, scale-degree weights, pitch range 

and base octave

• Intervals: interval histogram (step-vs-leap ratio), average interval size

• Rhythm: note density (notes per beat), common durations and their weights, note/rest probability

• Velocity: mean, range, accent probability and amount

• Contour: detected melodic shape (ascending, descending, arch, valley, etc.) with strength

• Multi-dimensional transitions: context-aware Markov data tracking pitch class, interval, and duration bucket 

simultaneously

The model persists when you save the project.
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Instruments & Effects

Cantia

Cantia is a formant voice synthesizer that produces singing and vocal sounds through physical modeling of the 

human vocal tract. A glottal pulse generator drives three parallel bandpass filters (formants F1, F2, F3) whose 

frequencies and bandwidths are interpolated per-sample for smooth coarticulation between phonemes.

VOICE TYPES

6 voice presets shift the formant frequencies to model different vocal ranges: Soprano, Alto, Tenor, Bass, Whisper 

(noise-only, no glottal pulse), and Robot (narrow bandwidths, metallic character).

LYRIC INP UT

Type lyrics into the text field and Cantia parses them into syllables and phonemes automatically. Each note triggers 

the next syllable in sequence.

• Plain text: la la do re mi  — syllables parsed from natural text

• IPA brackets: [aa] [iy] [uw]  — direct phoneme control (28 phonemes available)

• Glide arrows: [aa>ow]  — smooth interpolation between two phonemes

• Stress: LA la LA la  — uppercase syllables get louder, brighter formants

• Sustain: ah_  — trailing underscore holds the last vowel

PARAMETERS

• Voice — Voice Type, Breathiness (0–1), Vibrato Depth (0–1), Vibrato Rate (Hz), Formant Shift (−1 to +1)

• Amp Envelope — Attack, Decay, Sustain, Release

• Phoneme — Speed (0.1–4×), Consonant Sharpness (0–1), Vowel Blend (0–1)

• Chorus — Toggle, Speed, Depth, Mix

• Reverb — Toggle, Size, Damping, Mix

• Master — Level, Voice Mode (Mono/Legato/Poly), Voices (1–8)

• Randomize (“!!!”) — Randomizes voice parameters for exploration

MULTI-STATE LYRICS
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Cantia supports up to 16 lyric states, each with its own text and voice character settings. Use the State Selector to 

switch between lyrics, or automate with a Sequencer node. Each state independently stores voice type, breathiness, 

vibrato, formant shift, and phoneme speed.

12 factory presets: Soprano, Alto, Tenor, Bass, Whisper, Robot, Choir Pad, Gregorian, Ethereal, Beatbox, Vowel 

Drone, Chant.

Chirusa — 4-oscillator subtractive synthesizer

Chirusa

Chirusa is Noemi’s built-in synthesizer. New instances load a random preset for instant sound. Click “Presets” to 

choose from 10 factory presets: Pluck, Velvet, Blade, Glass, Drift, Ember, Frost, Volt, Haze, and Spark.

PARAMETERS

• 4 Oscillators — each with Waveform (Sine, Triangle, Saw, Square, Pulse), Level, Tune, Fine Tune, Pulse Width

• Filter — Type, Frequency (20–20kHz), Resonance, Envelope Amount

• Amp Envelope — Attack, Decay, Sustain, Release

• Filter Envelope — Attack, Decay, Sustain, Release

• Master — Level, Voices, Mode (Mono/Poly)

• Randomize (“!!!”) — Randomizes all parameters for sound exploration
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Ostion — 8-slot drum sampler

Ostion

Ostion is Noemi’s built-in sample-based drum machine. 8 sample slots, each with Sample, Note trigger (36–43), Gain 

(0–2), and Pan (−1 to +1). Load your own samples or use the built-in drum sounds.

Leeroy

Leeroy is a synthesis-based drum machine with 8 channels of purely synthesized drum sounds. Unlike Ostion (which 

plays samples), Leeroy generates sounds from oscillators, noise, and envelopes — ideal for electronic, analog-style 

drum kits. Uses the same MIDI note mapping as Ostion (36, 38, 42, 46, 39, 45, 49, 51).

PER-CHANNEL PARAMETERS

Each of the 8 channels has 13 independent synthesis parameters:

• Oscillator — Wave Shape (Sine, Triangle, Saw, Square), Tune (−24 to +24 semitones), Pitch Decay (0.001–1s)

• Noise — Level (0–1), Color (200 Hz–16 kHz low-pass cutoff)

• Amp Envelope — Attack (0–0.1s), Hold (0–0.5s), Decay (0.01–5s) — AHD shape, no sustain

• Tone — Filter Cutoff (20 Hz–20 kHz), Resonance (0–1)

• Character — Drive (0–1, soft-clip saturation)

• Output — Level (0–1), Pan (−1 to +1)

PITCH ENVELOPE

The pitch envelope is the key to analog drum character. On each trigger, the oscillator frequency starts at 4× the 

base pitch and decays down to 1×. The Pitch Decay control sets how fast this sweep happens — fast decay gives kick 

thump, slow decay gives tom pitch glide, zero gives a steady tone.
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EDITOR

Click the channel tabs (Kick, Snare, Closed HH, Open HH, Clap, Tom, Crash, Ride) to edit each drum sound 

individually. Channel names are customizable. The Randomize button (“!!!”) randomizes only the currently selected 

channel. 8 preset kits: Default Kit, 808 Classic, 909 Analog, Minimal Techno, Industrial, Lo-Fi, Trap, Electro.

SimSim

SimSim — wavetable morphing synthesizer

SimSim is a wavetable morphing synthesizer with dual oscillators, a state variable filter, dual ADSR envelopes, an 

LFO, and built-in chorus and reverb effects.

OSCILLATORS (×2)

Each oscillator reads from one of 8 wavetable stacks (Basic, PWM, Formant, Digital, Metallic, Warm, Ethereal, Vocal) 

generated via additive synthesis. The Morph knob crossfades between waveforms within the selected stack.

• Wavetable: Stack selection (8 stacks)

• Morph: 0–1 interpolation within the stack

• Tune: −24 to +24 semitones

• Fine: −100 to +100 cents

• Level: 0–1 amplitude

• Unison: 1–4 voices with Detune spread

• Pan: −1 to +1 stereo position

FILTER
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Cytomic SVF filter with stable per-sample modulation:

• Type: Off, Low-Pass, High-Pass, Band-Pass

• Frequency: 10–22,000 Hz

• Resonance: 0–1

• Envelope Amount: 0–1 (depth from filter envelope)

ENVELOPES & LFO

• Amp ADSR: Attack, Decay, Sustain, Release

• Filter ADSR: Separate envelope for filter frequency

• LFO: Sine, Triangle, Saw, Square, or Sample-and-Hold routable to Osc1 Morph, Osc2 Morph, Pitch, or Filter with 

Rate (0.1–20 Hz) and Depth controls

EFFECTS

• Chorus: Toggle, Speed, Depth, Mix (modulated stereo delay)

• Reverb: Toggle, Size, Damping, Mix

MASTER

• Level: 0–1 output amplitude

• Voice Mode: Mono, Legato, or Polyphonic (1–8 voices)

SimSim includes 12 factory presets: Morphscape, Digital Pluck, Warm Bass, Crystal Bell, Vocal Drift, Glitch Lead, 

Ethereal Strings, PWM Lead, Texture Wash, Formant Stab, Metal Pad, Sub Wobble. The Randomize button (“!!!”) 

generates new patches. The wavetable display in the editor renders the morphed waveform in real-time.

Internal Effects

Internal Effects — 7 built-in effects with presets and randomizer
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Noemi includes 7 built-in audio effects that require no external plugins. Each effect has 8 factory presets and a 

Randomize button (“!!!”) for sound exploration. Add effects via the Effects toolbar button or right-click canvas menu.

Effect Parameters Presets

Reverb Room Size, Damping, Mix, Width Small Room, Large Hall, Cathedral, Plate, 

Dark Chamber, Bright Air, Tight Ambience, 

Wash

Delay Feedback, Mix, Length Slapback, Quarter Note, Dotted Eighth, Tape 

Echo, Long Ambient, Ping Pong, Dub, Short 

Rhythmic

EQ (4-band) Frequency, Gain, Q per band Bass Boost, Treble Boost, Mid Scoop, Pres

ence, Warmth, Telephone, Air, Flat

Compressor Threshold, Ratio, Attack, Release, Output Gentle Glue, Bus Comp, Drum Squash, Vocal, 

Limiter, Slow Squeeze, Parallel Punch, De-

Peak

Chorus Depth, Width, Speed, Mix Subtle, Classic, Deep, Vibrato, Wide Stereo, 

Vintage, Shimmer, Detune

Phaser Depth, Rate, Feedback Gentle Sweep, Deep Phase, Fast Jet, Slow 

Swirl, Resonant, Subtle, Sci-Fi, Barber Pole

Multimode Filter Frequency, Type (LP/HP/BP) Dark, Muffled, Open, Radio, Sub Remove, 

Thin, Bright Pass, Rumble Cut, Vocal Focus, 

Mid Scoop

All effect parameters are available as modulation targets. Every effect node includes per-node gain and pan controls.

External Plugins

Noemi hosts AU, VST3, CLAP, and LV2 plugins for both instruments and effects. Supported formats by platform:

Platform Formats

macOS AU, VST3, CLAP, LV2

Windows VST3, CLAP, LV2

Linux VST3, CLAP, LV2, LADSPA

External plugin windows open in separate floating windows. CLAP plugins render their native GUI directly within 

Noemi. Plugin states are saved with the project.

Every instrument and effect node has per-node gain (−60 dB to +6 dB) and pan (Left to Right) controls.
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PLUGIN SETTINGS

Open File > Plugin Settings to view default scan paths and add custom plugin directories for each format. Default 

paths follow standard system conventions (e.g., ~/Library/Audio/Plug-Ins/VST3  on macOS). Use the Add 

button to include additional folders and the Remove button to delete custom paths. Custom paths persist across 

sessions. After adding paths, rescan plugins to discover newly installed plugins.

MIDI EFFECT PLUGINS

MIDI effect plugins (MIDI in / MIDI out) process MIDI data without producing audio. They are useful for arpeg

giators, chord generators, MIDI step sequencers, and other MIDI processing tools.

Automatic detection: AU plugins with the aumf  (MIDI Processor) type and VST3 plugins with zero audio I/O 

channels are automatically detected as MIDI effects. They appear in the Instruments menu with a “(MIDI Effect)” 

suffix.

Manual toggle: For plugins that register as instruments but function as MIDI generators (e.g., Stochas), open the 

plugin’s editor panel and enable the “Use as MIDI Effect” toggle to switch it to MIDI effect mode.

MIDI effect nodes display blue MIDI pins on both input and output, and a “MIDI FX” badge on the canvas. Connect 

them in a chain between a MIDI source and an instrument: Pattern → MIDI Effect → Instrument → Mixer. Multiple 

MIDI effects can be chained together.

When connected to an instrument, the MIDI effect plugin is automatically moved onto the instrument’s Tracktion 

Engine track (before the instrument in the plugin chain), allowing the DAW engine to handle MIDI processing 

transparently. When disconnected, the plugin returns to a muted holding track.
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Modulation
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The Modulation Matrix panel
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The modulation system lets you animate any parameter over time using modulation sources routed through the 

modulation matrix.

MODULATION SOURCES

Source Description

LFO Periodic waveforms (Sine, Triangle, Square, Saw, Reverse Saw, Random). Free-running or 

tempo-synced with 12 note divisions.

Envelope ADSR envelope triggered by note events from a selected node.

Step Sequencer Per-step levels (−1 to +1) with configurable rate, step count, and optional smoothing.

Random Sample & Hold, Smooth, or Noise modes with rate and smoothness controls.

Follower Envelope follower that tracks audio level from a selected node with attack, release, and 

sensitivity.

Sidechain Triggers ADSR envelope or gate from audio threshold crossings. Envelope and Gate modes.

Macro Manual 0–1 knob with optional MIDI CC learn for hardware control.

MIDI Maps incoming MIDI CC, velocity, aftertouch, or pitch wheel as a modulation signal with 

channel filtering and smoothing.

MiniNotation Evaluates a mini-notation pattern as a continuous 0–1 modulation value with rate and 

smoothing controls. Supports all pattern operators and continuous functions (sine, saw, etc.).

OSC Maps an incoming OSC address to a continuous modulation signal with address learning, 

range mapping (min/max), bipolar mode, and smoothing.

Automation Breakpoint envelope that records and plays back parameter changes over the song timeline. 

Supports Linear, Step, and Smooth interpolation.

AUTOMATION

The Automation source records and plays back parameter changes as a breakpoint envelope over the song timeline. 

It integrates with the existing modulation routing — an Automation source is just another modulation source that 

you route to targets via the modulation matrix.

Recording

There are two ways to record automation:

Global Arm Click the Rec button in the transport panel to arm all Automation sources simultaneously. When 

armed, any routed parameter change is captured as breakpoints while the transport plays. Click Rec again (or 

stop playback) to disarm.

Per-Source Arm Click the Rec button in an individual Automation source’s lane panel to arm only that source.

While recording, the playhead turns red in the automation lane and a red tint overlays the editing area.
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After recording stops, breakpoints are automatically thinned using Ramer–Douglas–Peucker simplification to reduce 

point count while preserving the curve shape.

Editing

The automation lane shows a visual breakpoint envelope editor. It appears in the Modulation Matrix panel when an 

Automation source is selected, and can also be opened in a resizable pop-out window via the open-in-new button.

• Double-click the lane to add a breakpoint

• Click and drag an existing breakpoint to move it

• Right-click a breakpoint to delete it

• Shift-click and drag to freehand-draw a curve (breakpoints are added along the stroke and thinned on release)

The interpolation mode selector controls how values are interpolated between breakpoints:

Linear Straight-line interpolation between points (default)

Step Holds each value until the next breakpoint

Smooth Hermite (ease-in-out) interpolation for gentle curves

The lane displays beat grid lines, section boundaries from the arrangement (if active), and a moving playhead during 

playback.

Playback

Automation sources sync to the transport position. During playback, the source evaluates its breakpoint curve at 

the current beat and outputs the interpolated value, which flows through modulation routing like any other source. 

Automation stacks with other modulation via the standard depth and curve controls.

ROUTING

To create a modulation route:

1. Add a modulation source

2. Click “Add Route” on the source

3. Choose a target parameter from the dropdown

4. Adjust the depth knob (−1.0 to +1.0)

Negative depth inverts the modulation. Multiple sources can modulate the same target (their effects are added 

together).

Each route card expands to show three rows of controls:

Depth −1.0 to +1.0 — amplitude and polarity of the modulation

Rate 0.25× to 4× — scales the source speed per-route so one LFO can drive different targets at different speeds (only 

affects periodic sources: LFO, Step Sequencer, Random)

Curve Response shaping applied before depth scaling

Response curve types:

Curve Behavior

Linear Direct 1:1 modulation (default)

Exponential More dramatic response toward the extremes

Logarithmic More sensitive near zero
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S-Curve Smooth sigmoid — gradual start and end

During scene crossfades, rate multipliers interpolate smoothly between scenes while curve types switch discretely 

at the crossfade end.

CROSS-MODULATION

Modulation sources expose their own parameters as modulation targets, enabling sources to modulate each other. 

For example, one LFO’s frequency can be modulated by another LFO, or an envelope’s attack time can be driven by 

a macro knob.

Available cross-modulation targets vary by source type:

• LFO: Frequency, Phase Offset

• Envelope: Attack, Decay, Sustain, Release

• Step Sequencer: Rate, individual step values

• Random: Rate, Smoothness

• Follower: Attack, Release, Sensitivity

• Sidechain: Threshold, Attack, Decay, Sustain, Release

Cross-modulation targets appear in the standard target dropdown alongside node parameters.
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Microtuning

Noemi supports microtuning via the MTS-ESP standard, allowing alternative tuning systems beyond standard 12-

tone equal temperament. Access via File > Microtuning Settings.

MODES

Off Standard 12-TET tuning (default)

Client Connect to an external MTS-ESP master plugin

Master Act as the MTS-ESP master, loading custom tunings

In master mode, load SCL (Scala) files for interval definitions and KBM files for keyboard mapping. When micro

tuning is active, Noemi uses MPE-style per-note pitch bend for accurate intonation.
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Transport & Mixer

Mixer panel with per-track faders and metering

Transport Controls

Play/Stop Start or stop playback (spacebar)

Reset Return to beat 0

Tempo Current BPM, displayed in the transport bar

Position Current playback position shown as bars:beats

Panic All-notes-off button, silences all active voices immediately

Metronome Toggles the click track, with an adjacent volume knob. It clicks each beat with an accented downbeat 

whenever enabled and the transport is playing, and always clicks through a recording count-in.

TAP TEMPO

Click the tap-tempo button in the transport bar rhythmically to set BPM. The algorithm averages up to 5 tap intervals 

for a stable reading. If you stop tapping for 2 seconds, the counter resets so your next tap sequence starts fresh.

TEMPO MODULATION
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Tempo is available as a global modulation target. Route an LFO, Envelope, Step Sequencer, or Random source to 

“Tempo” in the Modulation Matrix to create tempo changes over time. Modulated tempo stays local and does not 

propagate to Ableton Link peers.

ABLETON LINK

Noemi supports Ableton Link for tempo and transport synchronization with other Link-enabled apps and devices 

on your network.

Enable/Disable Toggle Link via the transport bar Link button

Tempo sync When Link is active, tempo changes propagate bidirectionally

Transport sync Start/stop commands sync across all Link peers

When Link is active, the tempo display reflects the shared Link session tempo. Tap-tempo changes propagate to 

Link peers. Tempo modulation from the Modulation Matrix stays local to Noemi.

Master Key

The master key selector in the toolbar sets the global key for the project (root note + scale type). The master key 

influences generators and scale quantizers throughout the project.

Mixer

Toggle the mixer panel with the Mixer toolbar button. The mixer supports up to 16 channel strips. Each channel has 

independent controls, even when multiple channels share the same sound source.

PER-CHANNEL CONTROLS

Each channel strip includes:

VU Meters Stereo level meters with graded color (green, yellow above −18 dB, red above −6 dB) and peak hold 

with decay

Volume Channel volume fader with dB readout

Pan Horizontal stereo pan slider (−1 left to +1 right)

Mute (M) Silence the channel. Muting does not affect bus sends.

Solo (S) Solo this channel, muting all others

BFX1 / BFX2 Send knobs for Bus Effect 1 and 2 (see Bus Effects below)

Track Label Numbered label (e.g., “1. Chirusa”, “2. Delay”)

Use the 8ch / 16ch button to toggle between 8 and 16 channel slots.

CHANNEL LABELS
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Channel strips show numbered labels in “1. Name” format for clear identification. Double-click any label to rename 

it (e.g., “2. Ambience”). Custom names persist in the project file.

Right-click a volume or pan control to assign a MIDI CC for hardware control.

BUS EFFECTS

Bus effect routing — Bus Out ports on the Mixer node connect to effect chains

The mixer provides 2 send/return effect buses (BFX1, BFX2) for shared effects like reverb and delay.
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Bus Sends Each channel strip has BFX1 and BFX2 send knobs (0.0 to 1.0) that control how much signal is sent to 

each bus

Pre-Fader Bus sends are pre-fader — a muted or silenced channel can still feed its bus effects

Bus Returns Each bus has a return volume fader and mute button at the right side of the mixer

Bus VU Meters Small level indicators on each bus return strip show audio activity

Canvas Bus Routing: The Mixer node on the canvas has Bus Out and Bus In ports on its bottom edge. Connect 

Bus Out 1 to an effect node (e.g., Delay), then connect the effect output to Bus In 1. Adjust BFX1 send knobs on each 

channel strip to taste. Repeat with Bus Out 2 / Bus In 2 for a second bus.

SPECTRUM ANALYZER

Spectrum analyzer — 96-band logarithmic frequency display

Click the Spectrum button in the mixer header to display a 96-band logarithmic frequency analyzer (40 Hz–18 kHz) 

to the right of the channel strips. The analyzer merges audio from all active tracks into a unified frequency view, 

using a 1024-point FFT with Hann windowing at a 30 Hz refresh rate. Band values are smoothed for stable visual 

feedback.

MASTERING CHAIN

Click the Mastering button in the mixer header to open the mastering chain panel. The mastering chain is a 4-stage 

processor on the master output. Each stage can be independently bypassed, and the entire chain has a global bypass 

toggle.

The four stages process audio in fixed order:
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Mastering EQ — 8-band parametric with spectrum analyzer

Stage 1 — Parametric EQ (8 bands): Shape the overall tonal balance with High Pass, Low Shelf, Bell, High Shelf, 

and Low Pass filter types. Per-band frequency, gain (dB), Q, and enable toggle. A spectrum analyzer shows a rainbow 

gradient when EQ is active, and grey when bypassed.

Stereo Imager — per-band width control with particle visualization

Stage 2 — Stereo Imager (4 bands): Control stereo width independently across 4 frequency bands separated by 

3 adjustable crossovers. Width ranges from 0 (mono) through 1 (normal) to 2 (wide). An animated particle fan 

visualization shows the stereo field spread per band, with a correlation meter (−1 to +1).

Multiband Dynamics — per-band compression with gain reduction metering

Stage 3 — Multiband Dynamics (4 bands): Independent compression per frequency band with threshold (−60 to 

0 dB), ratio (1:1 to 20:1), attack (0.1–100 ms), release (10–1000 ms), makeup gain (0–24 dB), and soft knee (0–12 dB). 

Per-band gain reduction metering.
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Maximizer — brickwall limiter with waveform history

Stage 4 — Maximizer: Lookahead brickwall limiter with threshold (−12 to 0 dB), ceiling (−3 to 0 dB), and release 

(10–500 ms). Gain reduction meter, stereo output peak meters, and a rolling waveform history showing input/output 

peaks.

Each stage has its own preset library accessible via the preset button on the stage tab. Imager and Dynamics presets 

also reset crossover frequencies to defaults. The mastering chain state persists in the project file.
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Scenes

The scene system lets you save and recall snapshots of your entire project state. Noemi provides 16 scene slots for 

storing and switching between different configurations during a performance or composition session.

What a Scene Captures

A scene stores a complete snapshot of your project’s current parameter state:

Data Description

Node states Active state index (A–P) for each Pattern, Generator, and Rhythm

Modulatable params All per-node modulatable values (transpose, velocity scale, swing, etc.)

Plugin patches Full instrument and effect plugin state (Chirusa, Ostion, external VST/AU)

Gain and pan Per-node gain and pan settings

Modulation routing All modulation source configurations and route topology

Modulation depths Per-route depth, rate multiplier, and curve type

Tempo Current BPM

Master key Root note and scale

Scene Panel

The scene panel is a horizontal strip at the top of the canvas area showing 16 numbered scene slot buttons and a 

crossfade beat selector.

Cmd+Click a slot Capture the current project state into that slot

Click a slot Recall the scene stored in that slot

Right-click a slot Context menu — Capture Here, Rename, Clear

Empty slots appear dim. Populated slots show their name or number. The active scene is highlighted with an accent 

color.

Crossfade
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When recalling a scene, choose how the transition happens using the fade duration dropdown:

Setting Behavior

Instant Immediate switch with no interpolation

1 beat Crossfade over 1 beat

2 beats Crossfade over 2 beats

4 beats Crossfade over 4 beats (default)

8 beats Crossfade over 8 beats

16 beats Crossfade over 16 beats

During a crossfade, float parameters (gain, pan, tempo, modulatable params, modulation depths) interpolate 

smoothly from the current values to the target scene values. Discrete content (note patterns, plugin patches, 

modulation routing, master key) switches at the end of the crossfade window.

Bar-Quantized Recall

When the transport is playing and a non-instant crossfade is selected, scene recalls are queued until the next bar 

boundary. This keeps transitions rhythmically aligned. The pending scene slot pulses on the scene strip until the 

bar boundary triggers the change.

When the transport is stopped, scenes are recalled immediately regardless of fade setting.

Scene Hotkeys

Scenes 1–10 can be recalled and saved via keyboard shortcuts:

• Cmd+1  through Cmd+0  recall scenes 1–10

• Cmd+Shift+1  through Cmd+Shift+0  save to scenes 1–10

Scene hotkeys respect the current crossfade setting.

Serialization

Scenes persist across project save and load. All 16 slots (including names, captured data, and the active scene index) 

are stored in the .nmi  project file.
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Song Arrangement

The arrangement system gives songs defined structure and length by organizing a timeline of sections, each refer

encing a scene slot. When enabled, the transport follows the arrangement timeline, automatically recalling scenes 

at section boundaries.

Arrangement Panel

The arrangement panel is a horizontal timeline strip inside the transport bar, to the right of the position display. 

Click the Arr button to enable/disable the arrangement.

• Click + to add a new section

• Double-click a section to edit its name, length, scene assignment, crossfade duration, and random seed

• Drag the right edge of a section to resize it

• Right-click a section for options (edit, insert before/after, delete)

Each section is displayed as a colored bar labeled with its name. The current playback position is shown as a moving 

indicator.

Song Structure Generator

Access via Edit > Generate Song Structure. This tool automatically creates a multi-section arrangement from built-

in song templates.

Template Choose from song forms (e.g., Verse-Chorus, ABAB, Build-Drop). A visual preview shows the section 

layout.

Intensity Controls the overall energy and variation level (0–1).

Seed Random seed for reproducible generation. Click “Random” for a new seed.

When you click Generate, the tool analyzes existing project content and creates arrangement sections with scene 

assignments, crossfade transitions, and per-section random seeds for reproducible non-determinism.

Sections

Each section has:

Name Display label (e.g., “Intro”, “Verse 1”, “Chorus”)

Length Duration in bars
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Scene Which scene slot to recall when this section begins (−1 = no change)

Crossfade Transition duration in beats when entering this section

Random Seed Seed for reproducible non-determinism within the section (0 = free)

Sections play sequentially. When the transport reaches a section boundary, the assigned scene is recalled with the 

specified crossfade. If automation sources are present, their curves align with the arrangement timeline.

61



Noemi Documentation Tweakbench

Performance View

The Performance View is a simplified full-screen mode designed for live performance. It replaces the main editing 

layout with large, stage-friendly controls: scene triggers, macro knobs, transport, and mixer meters with volume 

faders.

Activate via F11  or View > Performance View. Press Escape  to return to the normal editing layout.

Layout

The performance view is divided into four sections:

Transport Strip Play, Stop, and Reset buttons along with BPM display and a bars:beats:ticks position readout. An 

“Esc to exit” hint appears on the right.

Scene Grid A 4×4 grid of 16 scene pads. Click a pad to recall, Cmd+Click  to capture. A crossfade beats selector 

controls transition duration. Visual states include active (accent color), pending (pulsing), and crossfading 

(pulsing with progress bar).

Macro Knobs Horizontal sliders for all macro knob modulation sources in the project. Values sync bidirectionally 

— moving a slider updates the source, and MIDI CC changes from hardware are reflected in the slider position. 

If no macro knobs exist, a “No macros” placeholder is shown.

Mixer Strip Per-track stereo VU meters with peak hold indicators and vertical volume faders. Track names are 

derived from the sound source feeding each mixer input.

Keyboard Behavior

While in Performance View, most keyboard shortcuts are disabled to prevent accidental edits. Only the following 

commands remain active:

• Space  — Play / Stop

• Escape  — Exit Performance View

• F11  — Toggle Performance View

• End  — MIDI Panic

• Cmd+1  through Cmd+0  — Recall scenes 1–10

• Cmd+Shift+1  through Cmd+Shift+0  — Save to scenes 1–10

All four color themes are supported. The view responds to theme changes in real-time.
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Presets & Patches

Preset Browser

Open the Preset Browser with Cmd+Shift+P  or the Presets toolbar button. It provides a searchable library of node 

presets organized by categories with tags and favorites.

• Click a preset to load it into the currently selected node

• Use the search bar to filter by name

• Star presets to mark them as favorites

SINGLE PRESET EXPORT/IMPORT

• Export: Save the selected node’s configuration as a .nmp  file to share with others

• Import: Load a .nmp  file to apply a preset to the selected node

MULTI-NODE PATCH EXPORT/IMPORT

• Export Selection ( Edit > Export Selection ): Save multiple selected nodes with their connections and 

modulation routing as a .nmpatch  file

• Import Patch ( Edit > Import Patch ): Load a .nmpatch  file — nodes are created with new unique IDs 

and internal wiring is reconnected automatically
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File Operations

NEW / OPEN / SAVE

New Project Cmd+N  — creates a fresh empty project. On first launch (when no project is loaded), Noemi generates 

a randomized demo composition with a random MIDI clip, random scale and root note (via Scale Quantizer), 

a random synth (Chirusa or SimSim), a random drum machine (Ostion or Leeroy), and 0–2 random effects per 

chain. Each session produces a unique starting point for exploration.

Open Cmd+O  — file browser to load a .nmi  project

Open Recent Access previously opened projects

Save Cmd+S  — saves to the current file

Save As Saves a copy to a new location

Project files use the .nmi  extension and contain all node configurations, connections, modulation routes, plugin 

states, and embedded audio data.

RANDOMIZE PROJECT

File > Randomize Project generates a complete random composition — random nodes, connections, instruments, and 

effects. This is useful for creative inspiration or as a starting point that you can refine.

DEMO PROJECTS

File > Demo Projects opens bundled example compositions demonstrating various features of Noemi, including 

generative melodies, drum programming, granular synthesis, modulation routing, and scene-based live performance.

PROJECT DETAILS

File > Project Details lets you add metadata text to a project. Use it to store notes about the composition, credits, or 

any other descriptive information. Metadata is saved with the .nmi  project file.

EXPORT AUDIO

File > Export Audio ( Cmd+E ) opens the Export Audio dialog with the following options:

Render Scope:

• Entire Song — renders the full arrangement duration (or 2 minutes if no arrangement is active)

• All Arrangements — renders each song section as a separate file, useful for stems per section

• Time Duration — renders a custom duration in minutes:seconds
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Track Output:

• Single Mixed WAV — one stereo mixdown file

• Multitrack WAV — one WAV per mixer channel, named after the sound source (e.g. 01_Chirusa.wav , 

02_Ostion.wav ), all padded to equal length

Multitrack Options (when Multitrack is selected):

• Include Bus FX — include bus effect return tracks in the multitrack export

• Include Mastering — apply the mastering chain to the mixed output

Also export MP3 mix — optionally converts the stereo mix to MP3 ( 192kbps VBR) via the bundled LAME encoder.

Exports are saved into a timestamped folder. Filenames include tempo and master key when available (e.g., 

MyProject_120bpm_Cmaj_Mix.wav ). When combining All Arrangements with Multitrack, each section gets its 

own subfolder. A progress bar shows rendering status with the option to cancel.

AUTOSAVE & CRASH RECOVERY

Noemi periodically saves your project state in the background. If the application crashes, you will be offered the 

option to recover your work on the next launch.

DRAG AND DROP

• Drag a MIDI file ( .mid ) onto the canvas → new Pattern node

• Drag an audio file onto the canvas → new Waveform node

• Drag an audio file onto an existing Waveform → replace its audio

• Supported audio formats: WAV, AIFF, FLAC, MP3, OGG
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Keyboard Shortcuts

All keyboard shortcuts are customizable via File > Keyboard Shortcuts. The dialog shows every command grouped 

by category. Click a row to enter listening mode and press a new key to rebind. Right-click to reset a single command. 

Custom bindings persist across sessions in preferences.xml .

When the QWERTY virtual keyboard is active ( Cmd+K ), bare letter and digit keys are reserved for MIDI input and 

will not trigger shortcuts.

Default Shortcuts

Shortcut Action

Cmd+N New Project

Cmd+O Open Project

Cmd+S Save

Cmd+Shift+S Save As

Cmd+E Export Audio

Cmd+, Audio Settings

Cmd+. MIDI Settings

Cmd+Z Undo

Cmd+Shift+Z Redo

Cmd+C Copy

Cmd+X Cut

Cmd+V Paste

Delete  / Backspace Delete selected node(s)

Cmd+G Group selection
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Cmd+Shift+G Ungroup

Space Play / Stop

End MIDI Panic (all notes off)

Cmd+= Zoom in

Cmd+- Zoom out

Cmd+F Fit to window

Home Reset view

Tab Toggle minimap

Cmd+K Toggle QWERTY keyboard

Escape Exit group view

Cmd+Shift+M Modulation Matrix

Cmd+Shift+N Mixer

Cmd+Shift+P Presets

Cmd+Shift+T Tooltips

F1 Documentation

F11 Performance View

Cmd+1  – Cmd+0 Recall scenes 1–10

Cmd+Shift+1  – Cmd+Shift+0 Save to scenes 1–10

67



Noemi Documentation Tweakbench

Color Themes

Noemi includes 4 color themes, selectable from the View > Theme menu. The active theme applies a full semantic 

color palette across all UI elements — canvas, panels, meters, connections, badges, and text.

Theme Description

Dark Default abstract geometric dark theme

Light Inverted light theme for bright environments

High Contrast Accessibility-focused with maximum contrast

Midnight Deep dark variant with cooler tones

Theme preference persists across sessions. Switching themes triggers a full cascade repaint across all windows.

UI Scale

View > UI Scale offers 9 zoom levels (50%, 62%, 75%, 87%, 100%, 125%, 150%, 175%, 200%) for the entire interface. 

Useful for high-DPI displays where the default sizing feels too small, or for seeing more of the canvas at once on 

lower-resolution screens. The selected scale persists across sessions.
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Accessibility

Noemi supports macOS VoiceOver for screen reader navigation across all UI elements.

CANVAS & NODES

The composition canvas is an accessible group container. Each node on the canvas has a custom accessibility handler 

that exposes:

• Title: the node’s display name (e.g., “Pattern 1”, “Chirusa”, “Delay”)

• Description: the node name plus a summary of input and output connection counts

• State: focusable and selectable, with selected state tracking

• Actions: Press to select, Show Menu to open the editor panel

VOICEOVER ANNOUNCEMENTS

Noemi posts screen reader announcements for key events:

• Node added, deleted, or selected for editing

• Connection created or deleted (with source and target names)

• Transport play and stop

• Project saved and loaded

CONTROL LABELS

All interactive controls across every editor panel have accessibility titles: sliders, combo boxes, buttons, and toggles. 

This includes the transport bar (Play, Stop, Record, Tempo, Position), mixer strips (Volume, Pan per channel), 

modulation matrix controls, arrangement panel buttons, automation lane, and velocity editor.

KEYBOARD NAVIGATION

Press C to connect the selected node (opens a target picker menu) and D to disconnect (shows a list of connections 

to remove). These shortcuts enable fully keyboard-driven graph editing alongside standard Tab and arrow-key 

navigation.
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N O E M I

tweakbench.com
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